Results 1 to 5 of 5

Thread: Can't build a new super mine

  1. #1

    Exclamation Can't build a new super mine

    I have tried for the last few hours to build a new super mine, with no success I have sufficient Gulid coins I am the leader of the Gulid so I have permission to build I have tryed closing and reopening the app several times I have tried claming new land to put it on I have tried building it on different accounts with Buliding permissions I have tried restarting my phone, All these things to no success Time is money and my time is being wasted because, I could have had another cash mine up by now but instead nothing. Hopefully something can be done about this if not then Fuck it I guess I will have to go back to gathering Lvl 4 Cash villages for the rest of my life again...

    -TheChosen1 Z34

  2. #2
    The privs are all screwed up right now.

  3. #3
    Our guild mine is at 258% build right now lol 😂😂😆 members can't get troops back either

  4. #4
    It's Been Five days and I still can't build a Super Mine Wtf are you going to fix this?

  5. #5
    Our guild mine has been depleted. What was that means? Depleted by what? Who? We just need 5 more hours to get it done! What was going on?!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts