Results 1 to 5 of 5

Thread: Abnormal purchase approch - please help

  1. #1

    Abnormal purchase approch - please help

    Hello, first i would like to ask that you read all and not just post automatic answer.

    I had credits on my USA appstore region and i changed to this region to use the credits on Invasion.
    From that moment i canno't make any purchase on the game. i recieve an error msg "Abnormal purchase approch".
    I also can't change back to my israel reigon since i must use those credits i got in order to use them on the game only.

    I contact Apple and they said it's emerging problems and it's the developer responsibilty to solve it.

    My app store id is the same as it was before...only the region is different. i tried many things like delete the game , get out of app store then restart my phone and login to appstore agian and download the game. but nothing worked.

    I have money i lke to spend on the game...please help me resoulve the issue.

    Beside that i bought before two packs of value week card - research and construction. i never got my daimonds from the pack only the speedups.

    please help with that matter too.

    Thank you

  2. #2
    Hi, your request for me to read everything was moot. I do read through player's posts before I provide a reply. Try to keep in mind I am a dedicated player in this game and I strive to provide the best support possible.

    You've actually answered your own question. Switching regions on apple does not agree with security protocol Invasion has set up. I'm confused as to where you really live and why you were switching locations if you didn't move physical location, but at any rate, try leaving your base logged in for an extended period of time. The general rule of thumb is 8 hours... So leave your device on while you sleep. This usually helps the server to understand you're an actual player and not a resource loader (I do believe this to be the reason why the error happens in the first place).

    Long story short, there is no actual resolution. It usually just works itself out over time. I'm sorry if this isn't the answer you'd like, but it is the truth.

    As for dimes not received, you will need to messaged customer support on this. I dont have access to the tools needed to check the data.

    Hope this helps


    "Have you tried turning it off and back on again?"

  3. #3
    Thanks for your replay, I had that gift card which can be used only on USA app store. that's why i changed.
    I want to use the money on the game since i have nothing else to spend it on app store beside it.

    I think my phone was active more then 8 hours and it still didn't work. so now i'm stuck and can't move until i waste those dollars.
    I don't understand why tap4fun can't give me the access to buy stuff...but you are not the address for it.
    It also wierd there is no warning about it anywhere, i tried before to switch regions and it worked and only usa now not working...

    and support isn't helping much and everytime i wait like 48 hours from replay to's sucks

  4. #4
    Support doesn't get it tbh. I have spent over a year investigating this issue and it's still about as clear as mud lol. Let me dig through some notes and see if I have anything else I could suggest to you.

    Basically, easiest way to solve this issue is, no joke, get an Android


    "Have you tried turning it off and back on again?"

  5. #5
    ※Abnormal Purchase Error※

    This is an error unique to Apple users, but it does not affect majority of Apple users. If you get this error, it could be because of one of a variety of reasons.

    ◎Did you recently get this account and you're both
    Apple users?

    If this is the case, it's because the regions are
    different and the App Store knows the Invasion
    account is in a different region.

    To fix this, you have two options:

    1. If you have an Android device, use this account
    on that device
    2. If you do not have an Android device or would
    prefer this account on your Apple device, you will
    have to mail customer support to unbind the
    account and then bind it to a FB account of your

    ◎Did you recently do a return to your iTunes/App
    Store account?

    If so, you may see this error while the refund is

    ◎Do you owe money or have no balance available?

    You'll have to get that sorted (pay off balance or
    apply itunes card) and then the error should
    resolve itself.

    ◎Sometimes the error happens due to a connection
    issue. Switch to data if possible, reboot game. It's
    also worth it to reboot your device.


    This is something I wrote up a while ago. Not sure if anything is helpful :/


    "Have you tried turning it off and back on again?"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts