Results 1 to 6 of 6

Thread: [bug]Customor Service Not Working

  1. #1

    [bug]Customor Service Not Working

    Hello, I would like to report a bug about customor service button not working i click it and nothing opens/happens at all.

    Details: I click customor serivice button in game and nothing opens/happens.
    When the problem happened?: Well when i was trying to reach customor service 3-2 weeks ago i discovered it.
    How often the problem occured?: Well it never worked for me so..., i am suffering I can't reach customor service always to contact them about important things.


    Phone: iPhone 5
    Version: 9.2.1
    Screen Shots: i can't ptovide that :/
    Reigon: Africa --> Egypt
    Zone/Name: Zone: 231 / Name: Slammer

    Thanks for your time!
    End Of All Days Leader

  2. #2
    Please note that i need an answer urgently i lost lots of troops and i am sick of that, i lost them due to game bugs/servers offline and i want them back...... I can't reach customor service and no one is helping me..............
    End Of All Days Leader

  3. #3
    They usually only respond once every 24 hrs if that. And if they do respond they really dont give a fly sht about you, your problems, or anyone else. They care that people spend money. I say boycott and everyone start cases with google and apple and let invasion fail!

  4. #4
    Sorry for the delay of reply. We apologize for the inconvenience brought to you. The log-in issue has been fixed already and you can log in the game normally. Players who got attacked during the period of log-in issue have been given troops back. And also, we have delivered the below compensation, please collect them timely:

    - 2000 diamonds *x1
    - 150000 oil x 8
    - 150000 steel x 5
    - 50000 cash x 5
    - 30min speed up x 10
    - 60min speed up x 15

    Thanks for your understanding.

  5. #5
    Excuse me, i cant even contact customor service at all since the button ISN'T WORKING not that they dont want to respond

    Help please
    End Of All Days Leader

  6. #6
    Quote Originally Posted by Ali Ahmed View Post
    Excuse me, i cant even contact customor service at all since the button ISN'T WORKING not that they dont want to respond

    Help please
    Hi Ali. I am sorry. May I know your current game version? Please go to more-settings to check the game version. Our current version is 1.30.3. If your version is not the latest one, please re-install our game to have a try again. If it still doesn't work for you, please provide the following information for investigation.
    1.Your game version
    2.Your device type
    3.Your device system operation version
    4.A small video of this issue.

    Please excuse me for not getting your problem. Thanks for your understanding.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts